Bronco Hut    

   Ford Bronco Parts - Classic Vintage Early Bronco Parts   Toms Bronco Parts   BC Broncos
Community
 Message Forum
 Photo Gallery
 Event Calendar
 Book Reviews
 Bronco Wallpaper
 Bronco FAQ
 Link Back to CB!
 600+ Bronco Links!
 
Search all Bronco Links
Buy / Sell
 Classifieds / Want Ads
 Vendor Forum
James Duff
Rust Bullet
Sexton Offroad
Bronco Tech
Recent Tech Articles
 •Holley Carb Tips
 •Aussie Locker
 •C6 203 205 Doubler
 •4 Link
 •Clutch Replacement
 •Early Turn Signals
 •C4 Improvements
 •Threaded Dipstick
 •NV3550 5 spd
     More Tech...
Ford Bronco Parts - Classic Vintage Early Bronco Parts

Welcome to the ClassicBroncos.com Forums.

You are currently viewing our boards as a GUEST which limits your access to viewing only. To take advantage of all the forum features please take a moment to register. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact the admin. If you've lost your password click here.

Go Back   ClassicBroncos.com Forums > Archives > Bronco Tech - Archives

 
 
Thread Tools
Old 12/28/09, 05:26 PM   #1
bronco-billy-66
Bronco Guru
 
bronco-billy-66's Avatar
 
My Bronco is on the Atkins diet..No carbs

Madison Mississippi
Joined: Sep 03
Posts: 1,634
EFI RUNNING, with issues, Got ?'s

I got my efi finshed up today . And it runs ...351W ,truck lower,BC adapter,car upper. RJM harness..I ran out of time and couldnt set the timing at 10 deg. It runs alittle rough i hope timing fixes that..my alternator isn't charging, I hooked the ALT. wire on the RJM harness to the Green/Purple(hot in run) wire on the alt. is this right?? Here is the ALT diagram http://www.bcbroncos.com/2g%20alt%20...0watermark.pdf

Also it wouldn't fire the plugs with the ignition key.. I had to use a remote button, I know that is a no no. I've had a little trouble with the key switch in the past, had to move the key alittle to make the gauges work..not all the time just once or twice. Ran fine with the carb. Does this sound like i need a new key switch ? or is there something else i'm missing?? Thanks guys , I could never have gotten this far without CB.com

'66U13,Mass air EFI,351W,C4,Hydroboost,explorer serp,4x4x2 p/s,4.11 spooled 9in,D44detroit front,BB disc,3.5 BC lift,1" body lift,35's,warflares,Warn 8K winch
'68 F100 frame off under construction
bronco-billy-66 is offline  
Old 12/28/09, 06:03 PM   #2
Viperwolf1
Contributor
electron whisperer
 
Viperwolf1's Avatar
 
It's not dented, it's just been environmentally streamlined!

homelessly wandering
Joined: Aug 07
Posts: 23,278

My Gallery
Garage
If the ignition switch isn't working the alternator won't work either.

'74 beater, 5.0 mustang EFI, C4, PS, front discs, twin sticks, 3.5" susp/1" body, 33's, 4.11's, ARBs, Hickey Sidewinder, cobra hydroboost

'70 cruiser, 5.8 explorer EFI, 4R70W, PS, front discs + hydro, twin sticks, 3.5" susp/1" body, 34's, 4.88's, ARB & tru-track
Viperwolf1 is offline  
Old 12/28/09, 07:23 PM   #3
bronco-billy-66
Bronco Guru
 
bronco-billy-66's Avatar
 
My Bronco is on the Atkins diet..No carbs

Madison Mississippi
Joined: Sep 03
Posts: 1,634
Quote:
Originally Posted by Viperwolf1 View Post
If the ignition switch isn't working the alternator won't work either.
So did I wire the ALT. to the harness correctly?

'66U13,Mass air EFI,351W,C4,Hydroboost,explorer serp,4x4x2 p/s,4.11 spooled 9in,D44detroit front,BB disc,3.5 BC lift,1" body lift,35's,warflares,Warn 8K winch
'68 F100 frame off under construction
bronco-billy-66 is offline  
Old 12/28/09, 07:34 PM   #4
Viperwolf1
Contributor
electron whisperer
 
Viperwolf1's Avatar
 
It's not dented, it's just been environmentally streamlined!

homelessly wandering
Joined: Aug 07
Posts: 23,278

My Gallery
Garage
If you are using a 2g alternator and the "A" terminal is connected to the battery and the "S" terminal is connected to the stator terminal along with the "I" terminal to the ignition, then yes.

'74 beater, 5.0 mustang EFI, C4, PS, front discs, twin sticks, 3.5" susp/1" body, 33's, 4.11's, ARBs, Hickey Sidewinder, cobra hydroboost

'70 cruiser, 5.8 explorer EFI, 4R70W, PS, front discs + hydro, twin sticks, 3.5" susp/1" body, 34's, 4.88's, ARB & tru-track
Viperwolf1 is offline  
Old 12/28/09, 07:56 PM   #5
bronco-billy-66
Bronco Guru
 
bronco-billy-66's Avatar
 
My Bronco is on the Atkins diet..No carbs

Madison Mississippi
Joined: Sep 03
Posts: 1,634
Quote:
Originally Posted by Viperwolf1 View Post
If you are using a 2g alternator and the "A" terminal is connected to the battery and the "S" terminal is connected to the stator terminal along with the "I" terminal to the ignition, then yes.
Thats the way I have it.. Well the "A" terminal is on the + side of the starter selonoid,same thing right? I guess I'll see if The Zone has an ignition switch in stock. There website says 11.99, worth a try I guess. Any tricks to putting one of those in? Thanks viperwolf. I see your name on here allot. you're very knowledgeable.

'66U13,Mass air EFI,351W,C4,Hydroboost,explorer serp,4x4x2 p/s,4.11 spooled 9in,D44detroit front,BB disc,3.5 BC lift,1" body lift,35's,warflares,Warn 8K winch
'68 F100 frame off under construction
bronco-billy-66 is offline  
Old 12/28/09, 07:59 PM   #6
Viperwolf1
Contributor
electron whisperer
 
Viperwolf1's Avatar
 
It's not dented, it's just been environmentally streamlined!

homelessly wandering
Joined: Aug 07
Posts: 23,278

My Gallery
Garage
Same thing. Check the tech articles for ignition switch replacement.

'74 beater, 5.0 mustang EFI, C4, PS, front discs, twin sticks, 3.5" susp/1" body, 33's, 4.11's, ARBs, Hickey Sidewinder, cobra hydroboost

'70 cruiser, 5.8 explorer EFI, 4R70W, PS, front discs + hydro, twin sticks, 3.5" susp/1" body, 34's, 4.88's, ARB & tru-track
Viperwolf1 is offline  
Old 12/28/09, 08:23 PM   #7
bronco-billy-66
Bronco Guru
 
bronco-billy-66's Avatar
 
My Bronco is on the Atkins diet..No carbs

Madison Mississippi
Joined: Sep 03
Posts: 1,634
Quote:
Originally Posted by Viperwolf1 View Post
Same thing. Check the tech articles for ignition switch replacement.
Thanks. Looks easy enough. I would've never known about the paper clip trick. This site is awsome

'66U13,Mass air EFI,351W,C4,Hydroboost,explorer serp,4x4x2 p/s,4.11 spooled 9in,D44detroit front,BB disc,3.5 BC lift,1" body lift,35's,warflares,Warn 8K winch
'68 F100 frame off under construction
bronco-billy-66 is offline  
 

  ClassicBroncos.com Forums > Archives > Bronco Tech - Archives

Thread Tools

Forum Jump


All times are GMT -6. The time now is 10:55 PM.


Bulletin Board Software by: vBulletin
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.


This site created, owned and maintained by Jon Hanna
Copyright 1996-2018 All rights reserved. Privacy Statement
ClassicBroncos.com is not affiliated with Ford Motor Company

Page generated in 0.72268 seconds with 63 queries