Bronco Hut    

   Ford Bronco Parts - Classic Vintage Early Bronco Parts   Toms Bronco Parts   BC Broncos
Community
 Message Forum
 Photo Gallery
 Event Calendar
 Book Reviews
 Bronco Wallpaper
 Bronco FAQ
 Link Back to CB!
 600+ Bronco Links!
 
Search all Bronco Links
Buy / Sell
 Classifieds / Want Ads
 Vendor Forum
James Duff
Rust Bullet
Sexton Offroad
Bronco Tech
Recent Tech Articles
 •Holley Carb Tips
 •Aussie Locker
 •C6 203 205 Doubler
 •4 Link
 •Clutch Replacement
 •Early Turn Signals
 •C4 Improvements
 •Threaded Dipstick
 •NV3550 5 spd
     More Tech...
Ford Bronco Parts - Classic Vintage Early Bronco Parts

Welcome to the ClassicBroncos.com Forums.

You are currently viewing our boards as a GUEST which limits your access to viewing only. To take advantage of all the forum features please take a moment to register. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact the admin. If you've lost your password click here.

Go Back   ClassicBroncos.com Forums > 66-77 Ford Bronco > Bronco Chat > Vendor Forum & Current Mass Buys

Reply
 
Thread Tools Search this Thread
Old 04/06/17, 10:20 AM   #1
Bronc0311
Newbie
 
Austin
Joined: Jun 15
Posts: 20
Tv cable

I'm running a 5.0 Efi with aod. Installed winters shifter and trans started acting up. Won't shift properly and requires a high rpm to engage into 1st gear, runs through gears quickly and shifts hard. Tv cable had some janky fab done to the adjustment block on the cable so I pulled a used one from a junkyard. Still shifting hard and still requiring high rpm. Tried all the adjustment info I found on YouTube and mustang forums with no success in fixing my problem. Is there something I'm missing, are these cables notoriously diff to adjust or is a new one my best bet? Any suggestions would be greatly appreciated
Bronc0311 is offline   Reply With Quote
Old 04/15/17, 10:56 AM   #2
lbrendis
Contributor
Newbie
 
so cal
Joined: Aug 15
Posts: 33

My Gallery
Garage
Might want to move this post over to the tech forum!

72 with 302, AOD, disc/drum, hydraboost, 3.5 SL Larsbars,1" BL,35s KM2s,bilsteins w/F250 towers,4:56's 31 spline w/Yukons,
lbrendis is offline   Reply With Quote
Old 04/15/17, 11:51 AM   #3
wepuckett
Contributor
Sr. Member
 
Morganton, NC
Joined: Apr 14
eBay: wepuckett
Posts: 705

My Gallery
Garage
Lokar sells all the parts for that if you call them and tell them what is going on they will be very helpfull and give you all the part numbers so You can price out the best place to buy the parts.
wepuckett is offline   Reply With Quote
Old 04/15/17, 11:55 AM   #4
needabronco
Bronco Guru
 
needabronco's Avatar
 
Prescott/Farmington
Joined: Jul 04
Posts: 6,280

My Gallery
Id say your tv cable is binding or improperly adjusted. You need to set the tv cable by line pressure, you can jerry fab a cheap guage to do this. I run an Art Carr shifter and an AOD and Im usin BC Broncos tv and throttle cable.

When you installed your shift linkage your tv adjustments were changed.

1971 Mall Crawler- Resto mod. http://classicbroncos.com/forums/sho...dabronco+frame

1970 Basket case

1966 U14
needabronco is offline   Reply With Quote
Reply

  ClassicBroncos.com Forums > 66-77 Ford Bronco > Bronco Chat > Vendor Forum & Current Mass Buys

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Forum Jump


All times are GMT -6. The time now is 11:29 AM.


Bulletin Board Software by: vBulletin
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.


This site created, owned and maintained by Jon Hanna
Copyright 1996-2017 All rights reserved. Privacy Statement
ClassicBroncos.com is not affiliated with Ford Motor Company

Page generated in 0.25308 seconds with 55 queries