• Welcome to ClassicBroncos! - You are currently viewing the forums as a GUEST. To take advantage of all the site features, please take a moment to register. It's fast, simple and absolutely free. So please join our community today!
    If you have problems registering or can't log into your account, please contact Admin.
jimmyk

Latest activity Postings Images About

    • jimmyk
      Yes the track bar has the axle pulled to the drivers side, 100% normal with a lift. Adjustable track bar will allow the body to be...
    • jimmyk
      jimmyk replied to the thread Holley Sniper Pro?.
      Were you able to figure it out?
    • jimmyk
      200k and no pictures. Nice
    • jimmyk
      jimmyk reacted to Jmjuhl's post in the thread Ford Godzilla Crate Engine with Like Like.
      417 Motorsports also makes a shallower pan as well...designed for the Fox Body mostly. Just saw this video this morning...Gumby is...
    • jimmyk
      jimmyk reacted to sprdv1's post in the thread 2G to 4G help!! with Like Like.
      yeah for sure...
    • jimmyk
      jimmyk replied to the thread 2G to 4G help!!.
      I appreciate all your help.....hopefully its a non issue going forward. 🙏
    • jimmyk
      jimmyk replied to the thread 2G to 4G help!!.
      I looked and the red wire is on the same post that is being powered by the battery. Im out of town until the 23rd but brought my CENTECH...
    • jimmyk
      jimmyk replied to the thread 2G to 4G help!!.
      Its 130 amp. I'll have to take a look for the red wire, I can't remember right off.
    • jimmyk
      jimmyk replied to the thread 2G to 4G help!!.
      That makes sense.......also, I didn't realize my contributor status had expired so I renewed it....lets see if I can post some pics...
      • IMG_4658.jpg
      • IMG_4658.jpg
      • IMG_4657.jpg
    • jimmyk
      jimmyk replied to the thread 2G to 4G help!!.
      Yes, not exactly sure how they got broken but I suspect it was when he had someone else trying to install factory FI from a...
    • jimmyk
      jimmyk replied to the thread 2G to 4G help!!.
      So it turns out that we somehow got it out of time in changing the timing chain cover. It DOES have spark at the plugs. One thing i...
    • jimmyk
      jimmyk reacted to DirtDonk's post in the thread 2G to 4G help!! with Like Like.
      You have an incorrect interconnection. There’s no way a normally wired alternator affects the ignition and there’s no way that a wire...
    • jimmyk
      jimmyk reacted to Broncobowsher's post in the thread 2G to 4G help!! with Like Like.
      Unplug the alternator and check for power to the turn on wire. Forget the color, but function wise the one that goes to ignition. Not...
    • jimmyk
      jimmyk replied to the thread 2G to 4G help!!.
      I plan on going back later today and see what I can come up with.....will post later what I come up with. Thanks to you all.
    • jimmyk
      jimmyk replied to the thread 2G to 4G help!!.
      I'll have to investigate further, but we haven't done anything with the distributor besides remove it and reinstall it. I do agree sure...
  • Loading…
  • Loading…
  • Loading…
Top